Uncategorized

Easy Vpn Yapısı

Easy vpn oluşturma komutları sırası ile aşağıdaki gibidir, ilerleyen zamanlarda uygulamalı resim li anlatımını da hazırlayıp paylaşmaya çalışacağım.Kodlar Packet tracer üzerinde yazılmıştır.

Access List Oluşturma
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface s0/0/0 overload
int s0/0/0
ip nat outside
int f0/0
ip nat inside
exit

Static Route Yazma
ip route 0.0.0.0 0.0.0.0 100.100.100.2
ip nat inside source static tcp 192.168.1.2 80 100.100.100.1 80
ip nat inside source static udp 192.168.1.2 53 100.100.100.1 53

VPN Yapılandırması
ip havuzu hazırlama
ip local pool vpnpool 192.168.2.10 192.168.2.20
radius serverı aktif etme
aaa new-model
aaa authorization network vpnremoteaccess group radius
aaa authentication login vpnusers group radius
aaa authentication login default group radius

VPN Faz1
crypto isakmp enable
crypto isakmp policy 1
authentication pre-shar
encry 3de
group 2
exit

VPN Faz2
crypto isakmp client configuration group vpnremoteaccess
key burcu
netmask 255.255.255.0
pool vpnpool
exit
crypto ipsec transform-set vpntransform esp-3des esp-sha-hmac
crypto dynamic-map dynmap 1
set transform-set vpntransform
reverse-route
exit
crypto map clientmap client aconfiguration address respond

Policy’nin alınması için
cyrpto map clientmap isakmp authorization list vpnremoteaccess
Transform set’in alınması için
crypto map clientmap 65535 ipsec-isakmp dynamic dynmap
crypto map clientmap client authentication list vpnusers

interface s0/0/0
crypto map clientmap
exit
radius-server host 192.168.1.2 key 123